ヒラリー・オーマン
詳細情報
- 代表的な業績
- Oakley(RFC 2412)、RFC 3766
- 分野
- ネットワークセキュリティ、暗号プロトコル
鍵交換プロトコルOakleyの作者。OakleyはIKEの半分となり、あらゆるIPsecトンネルの内部に入っている。
1990年代にIPsecが標準化されていたとき、鍵合意の良い方法が欠けていた。1998年にRFC 2412として公開されたオーマンのOakleyは、グループを選択でき前方秘匿性を備えた認証付きディフィー・ヘルマン鍵交換のやり方を記述した。同時期にISAKMPおよびSKEMEと組み合わされてIKE(RFC 2409)になった。IKEが悪名高いほど複雑になった責任を一人に帰すのは難しい。三つのプロトコルを一着に縫い込んで、優雅に見えるほうが稀である。
2004年にはポール・ホフマンとRFC 3766を共著し、対称鍵の強度に見合う公開鍵の大きさを示した。この表は20年にわたり引用されている。DARPAのプログラムマネージャーを務め、IEEEのセキュリティ分野でも活動してきた。