ティム・ダークス
詳細情報
- 代表的業績
- TLS 1.0、1.1、1.2の編者
- 仕様
- RFC 2246
TLS 1.0の編者。SSLが改名されたのは、IETFがNetscapeの成果をそのまま承認したと言われないためだった、と後に語った人物。
IETFがNetscapeのSSL 3.0を引き継いだとき、ダークスはSSLツールキットを販売するConsensus Developmentに在籍していた。クリストファー・アレンとともに、1999年1月にRFC 2246、すなわちTLS 1.0を書き上げた。SSL 3.0からの技術的な変更は小さかったが、名前の変更は小さくなかった。本人によれば、ブラウザ戦争の中で、Microsoftが競合製品の名を冠した規格を採用せずに済むようにするための体面上の譲歩だったという。
その後TLS 1.1(RFC 4346、2006年)と、エリック・レスコラとの共同でTLS 1.2(RFC 5246、2008年)も編集した。TLS 1.2はその後10年にわたりウェブを支えたが、結果として、ほとんどの人がTLSのことを今でも「SSL」と呼んでいる。