IT用語集 › ネットワーク › STUN

STUN

ネットワーク Svenska → 更新: 2026-10-21

NAT の内側にいるクライアントが、自分のグローバル IP とポートを知るためのプロトコル。P2P(WebRTC、VoIP、ゲーム)の基盤である。

RFC 3489(2003年)に始まり、RFC 5389(2008年)、RFC 8489(2020年)へと更新された。クライアントが STUN サーバーに UDP パケットを送ると、サーバーは「あなたは IP/ポート X から来たように見えた」と返す。対称型 NAT では不十分なことがあり、その場合は TURN サーバーが通信を中継する。両者を合わせたものが ICE プロトコルで、WebRTC の背骨となっている。公開 STUN サーバーでは Google の stun.l.google.com:19302 が事実上の標準だ。

← 用語集に戻る